329

Lumia 920 ‘1314’ firmware gets announced, fixes AT&T phones with connection problems [Updated]

[Update: Nokia Care US is now claiming that this is for AT&T users, and it should be live. Our device is now updated at 1:22pm ET...]

While a lot of Lumia 920 owners are getting the 1308 firmware (which is busted for AT&T users, having been recently halted), Nokia is pushing out a follow up to it numbered 1314. That update, as far as we know, has not actually started to go to devices and it’s not currently on Nokia’s Navifirm server (the highest is 1310 for China’s Lumia 920T).

But it may be real close...

The update has a similar Changelog to the 1308 update, but looks to fix some connectivity problems that some users have been experiencing:

  • Improved automatic display brightness adjustment
  • Fix for intermittent screen blanking during a call
  • Improvements for connectivity issues in certain network conditions
  • Performance and stability improvements

That third point looks to be directly related to issues that AT&T users have been plagued with for just over two weeks now. Those problems have caused intermittent and unreliable data connections, often over LTE on Lumia 920s, causing much frustration for users.

No word on when this update is going out, though Nokia typically kicks off updates around 11am PT/1PM ET, meaning this could go live at any moment. We’ll of course follow up with any information as it comes in.

Source: Nokia; Thanks, canadian1der, for the tip!

8
loading...
57
loading...
50
loading...
0
loading...

Comments

There are 329 comments. Sign in to comment

Prodigy11 says:

Nice, hat tip to Nokia :)

aaa6112 says:

Downloading update right now...SoCal here.

drankurn says:

me too, DC metro area.

Quin 2013 says:

So excited, getting my update right now too!!!

San Francisco, CA.

big_slim750 says:

Same here! DC Metro area!

pookiewood says:

In the ATX updating now.

Update is now live!

x I'm tc says:

Let's hope it doesn't make something else worse.  Seems like every step forward with Windows Phone is offset by some other step backward.

Pappa Ed says:

1314 is in da house! New England.

Paul Kinslow says:

Have you tried Android updates? I question whether they are intended to get people so frustrated that they upgrade to a new phone. I'm still suffering with my HTC Incredible update.

MDak280 says:

Glad to see they're addressing the issue :)

fpostrow says:

Fantastic. Get this out ASAP.

slavrenz says:

Am I the only one with a Lumia 920 on AT&T that didn't have any issues with the recent firmware update? Which I suppose is ironic, in the sense that I'm on my 4th Lumia since November due to various other software problems!

bkaul says:

No, no problems here, either. I'm glad to have received the recent firmware update and have the auto-brightness control working properly again, and I haven't run into any connectivity issues.

oditius says:

No problems here either

It wasn't just the previous update, I've had this issue since launch.

Quin 2013 says:

Are you seeing any improvements since this new update?

dkp23 says:

Im on my 4th as well and i am having huge issues.  In strong LTE areas, i have minimal issues, if i am in a 4g/lte border area, major issues with massive drain. 

Jarocookies says:

About that border area, that has and will be a problem because smartphones will search for a better connection (you'd put 3G as maximum speed to tackle that drain)

blackhawk556 says:

I thought I had no problem until I started noticing no internet even with two bars and my live tiles for wpcentral, chronos calendar, battery life, and a couple of others completely stopped working

ahardin says:

I actually didn't experience any issues except for one time when at WalMart (which is another issue in itself).  After going across the street to get gas, I didn't have any more issues.  

Heavy Rain says:

I noticed but it didn't alter anything dramatically

Spicymikey says:

nope, I never had any issues either.  Did the update anyway.  Maybe it was causing issues I didn't notice

cursivek1d says:

No issues here!

mgw says:

My girlfriend and myself both have 920's and the last update caused problems. My battery life became horrible. I would lose internet connection even though I was showing a 4g connection. I would call my girlfriend and it would go straight to voicemail about half the time and some text messages were being missed. I hope this fixes it.

bsd107 says:

My ATT launch 920 eventually had all 3rd party live tiles stop working, and for months I could not get them back.
 
This was "fixed" when my 920 had a hardware failure and ate it's own battery.  The refurb replacement had 3rd party live tils working out of the box.
 
Portico, of course, then broke the live tiles.  Even with the latest update '1314', live tiles are still broken.
 
I used iPhones since the 3G, and still have an older one on iOS6, so know that alternative platforms are far from bug-free.
 
But this major functionality of WP8 NEVER working consistently, or breaking forever at a random point in time, is completely unacceptable, and will likely drive me back to iOS eventually.  I want a BETTER, MORE FUNCTIONAL platform than iOS.  If that basic functionality isn't working, I might as well suffer along with iOS instead and at least enjoy it's top-notch app library....

peacock93 says:

Let's hope it is soon!! Connectivity issues are driving me crazy!!

Kieta says:

Me too. Just checked and nothing yet here in Metro Detroit.

Kieta says:

Downloading now

WPmunkey says:

Everything internet related loads so fast and fluid now. Before when on WiFi or LTE it was soooo slow. Then my signal would randomly drop. Now it's better.

why are they leaving 820 behind!! no updates for poor chap, all updates only for big bro :(

blackhawk556 says:

This one is pretty much to fix their screw up from their last update.

benners76 says:

820 won't be far behing...
 

hb2p says:

I haven't had connectivity issues, but it will be nice to have live tiles working again!

blackhawk556 says:

I noticed this as well. Chronos calendar would stay stuck by not switching its tile to reflect the current date. That's how I noticed live tiles not working.

hb2p says:

I just did the update.  I'm not certain the live tile issue is fixed.. 

Heavy Rain says:

Its most likely the app.

fwaits says:

Check the forums on live tiles not updating.  There is a good fix for that that involves disabling all background tasks you can, clearing IE history/cache then retarting the device.  Open the apps in question and make sure they show as allowed in the background tasks again and wait to see if the tiles update again.  Worst case scenario if that doesn't help is uninstall those apps, clear the IE history, restart, then reinstall and they should work again.

Jason_JS_G says:

I'm still waiting for 1308 on an unbranded lumia 920 in Sweden.

rcasey says:

Same here in Korea. Annoying...

Same thing in UAE

Nakazul says:

Same here, Sverige GBG.

Denashi says:

Yea, same here in Denmark.

Milk21 says:

Same here in Melbourne, Australia.

danielgray says:

Same here in Sydney, Australia

Erik Larsson says:

Same here, unbranded Sweden on Telia . Soon to hit 10Gb in other and no update in sight, this is ridiculous.

Jason_JS_G says:

10 gbs, you should be happy. I'm on 13.52

Ali Babba says:

BUILD phones don't have it either.

link5a says:

Well folks, remember how we had to wait about a moth to get our hands on a 920 in Sweden? You didn't think that was it, did you? ;)

solution2u says:

Malaysia don't even have 1249 yet for 1st batch phone. LOL

J4rrod says:

The auto adjust for brightness thing, anyone else have a problem when you go outside, for example, and your phone's screen brightness turns up and then all the colors on your phone look INCREDIBLY washed out? I'm thinking that's what that means, it's going to fix it.

weisman87 says:

This is a feature. It's the "Sunlight readability" in the "display+touch" menu in Settings.

ncxcstud says:

That's a feature that has been in the 920 from the beginning. It is so you can see your phone in bright sunlight. It can be turned off in the display touch area in the settings menu.

sparkedfire says:

The phone does that on purpose so you can read the screen in full sunlight.  To disable, go to display+touch under settings and turn off sunlight readability.

sarim_xyz says:

Is this for AT&T exclusively?

Not sure, though the macro region designation is for AT&T, Rogers, and other N.American carriers. It depends on whether those carriers need it/request it, but since Nokia has not commented publicly, we just don't know yet.

sarim_xyz says:

Well, I'm still waiting for 1308 on unbranded Lumia 920 in India :(

Zeeshan360 says:

Nokia is busy in launching low end WinPho 8 in India .. It seems we won't get the update till May

sarim_xyz says:

No, it's available in India, it's just that I haven't got it. Maybe coz my phone is from MEA region. But again, it's available there too, as the website says. I guess, I should wait a few more hours.

I have a unbranded 920 from INDIA and i got the update after manually checked

Im glad they worked out the issue in a relatively fast manner. It hasn't been too much of an issue for me but it had started to become increasingly frustrating to deal with. All in all it wasn't too big of a problem and have gained no ill will over the situation.

Wander7 says:

Can't come soon enough...
 

n3rfh3rd3r says:

Phone says update is available now.  Downloading...

Daniel, do you think the two new features you mentioned in the previous article (double-tap to turn on display, always on clock) would be included in this update??

Definitely not. Those features are still being developed. What is in this update is what is listed above, nothing more.

My carrier pigeon will be happy when this is released. He has been working overtime ever since the 1308 update rendered my phone unreliable.

suruwal says:

I want this update badly as my phone is as slow as my old xperia s....it was blazing fast prior to the update....

xrs22 says:

Saw this earlier, hoping it fixes the issa's.

peacock93 says:

It's here everyone!! 1232.5962.1314.1 is now on NaviFirm!! Should drop to OTA soon.

winmopro says:

I can confirm that it is now OTA as my phone (after telling it to check for an update) is asking me to connect to Wifi.

pankaj981 says:

I think a lot of users are still waiting for the 1308, including the 810

Nakazul says:

+1. I dont know where there is a "lot" of users getting this. But it seems to be English talking places - Canada.

nizzon says:

I hope this fixes the Bluetooth-problems. If my headset drops connection its a feakin pain in the ass getting it reconnected to the musicplayer again.

mrdeezus says:

My issue is that if i have my bluetooth connected to car stereo BT and ise internet sharing at same time, when either connection turns off phone will freeze up.

Messy eh says:

I've also had that happen

dkp23 says:

ATT 920, ITS UPDATING!!!

Update is now LIVE folks for AT&T, go, go go

Heavy Rain says:

Daniel, your too kind to us. Thanks.

funkyGeneral says:

I have a Rogers phone unlocked on Wind's network. Will that affect whether I get any updates?

ttsoldier says:

No. The 1308 has not been released for rogers as yet.

Long Syntax says:

Done, no update issues at least

dkp23 says:

OH NOES, the dreaded cogs of death

z8er says:

Me too! Fingers crossed.

altacalifas says:

Downloading now in NorCal and crossing my fingers!

highercal says:

Mine is updating as we speak!! ATT White 920 in Los Angeles @ 10:27 AM.

jmikla says:

UPDATING!! Fingers crossed.... 1308 killed my data, hopefully this fixes it.

Update is now live

Jowiso says:

Just received my update - Lumia 920 on AT&T.
Downloading now......

SchueyF1 says:

Come on Rogers!

fpostrow says:

It's Live here on the East Coast.
-920 Black done & restarted - success
-920 Red done & restarted - success
-920 Cyan in the UK - checked for updates, found, downloaded and installed. After the install and migration it rebooted and would not turn on. Did a reset via power button down volume combo and phone restarted, shut back down and restarted again. Firmware and OS check and everything is up and running. - long distance sweaty palmed success
-920 Yellow - new phone received today, very quick install as the data migration was very short. - success

rossart12 says:

Downloading it right now...Northern California. Thanks to Nokia...although this probably shouldn't have to be happening anyway.

Shippin says:

Got several failed attempts, but it is downloading now (after I connected to WI-FI) Redmond, WA here.

jmikla says:

"Almost Done" Was at the point of flashing back a version, glad I busy at work before I did.
 

nizzon says:

So this is not coming to Europe? WTF is that about? :(

blackhawk556 says:

This is to fix their screw up from the last update. I wouldn't actually want this update but crap happens.

nizzon says:

Hopefully we get the clock and doubble-tap too, I see no reason why we shouldnt.

Nakazul says:

Mmm, and WP sold more over here then U.S so, what's going on indeed?

Updating now in Columbus, Ohio. L920

jayruguitar says:

Just started the cogs.  I cannot watch!

dkp23 says:

Mine was close to o10 minutes and i was like OH NO, buti t finally went through, patience

EugB says:

Thanks for the words of encouragment!  Wish there was some progress indicator...don't like the cogs anymore!  ;)

lottidah says:

Oh my gosh, I'm with you. Saw the cogs of death and freaked out!  I came here to see how long it should take before they go away.

jayruguitar says:

Migrating data.  Phew!

Well I had this problem so I told att and talked them into sending me a cyan Nokia Lumia 920 and sent them my black Nokia Lumia 920

moc426 says:

Dan, how long did it take to apply the update, I am on the gear screen for some time now.
Ok nevermind, its loading now :) Was getting worried.

me21n says:

Gears have been grinding for about 5 minutes now...ATT in Columbus,OH...getting worried...

EugB says:

I wouldn't worry..mine took over 5 minutes.  It's on the almost done screen now.

moc426 says:

Hooooooold Hooooold! :) it will get there.

me21n says:

Phone restarted after about 6-7 minutes of the cogs....now it says "almost done  migrating your data (Step 1 of 4) 15%....

hermanax says:

Not sure if I'm the only one, but after the spinning gears screen, I received a blue screen with the reading:
0% complete
If you'd like to know more about this error, you can search online
DRIVER CORRUPTED EXPOOL
 
 
I have no idea what this means...
 
update: I did the soft reset with the volume down and power keys and now it just has a black screen with a large, white text-sad face like this:    :-(

My Lumia 920 has 100% remaining battery before the update.
 
After the update, my phone only has 15% remaining battery. What's up with that?

You probably have to flash your phone to get it back

tonyfreak215 says:

Restart your phone. Mine did the same thing. A reboot (not soft reset) fixed it.

BikerCVG says:

After an hour of the gears grinding I got the same sad face...

Did the same soft reset and got the same sad face...

hermanax says:

Same here.
Instead of messing around with it, I just went into AT&T and told them I needed yet another warranty replacement. Should be here by Tuesday.
I've loved Windows Phone for a long time, but this all-to-often replacement deal is getting ridiculous. I'm not a fan of having to get a refurbished device every other month and having every single one be defective.

Looks like someone's getting a new phone! Woohoo!

Gavinr98 says:

Have the same problem with my baterry, before the update is was 95%, now its 20% and does not seem to be charging... did you find a fix ?

ricbon says:

LIVE IN SOAZ

DennisvdG says:

Is it normal that I do not even have the 1308 update yet? (the Netherlands)

Yes. This is the AT&T firmware.

DennisvdG says:

Strange I recall reading that the 1308 update was globally... My fault

dortyboy says:

Just downloaded. I was really mad at Nokia for jacking up my phone. I hope the update solves the issue

paulxxwall says:

Downloading now SW florida

ChrisLynch says:

That was a fast turnaround!  Downloading update now.  let's hope this fixes the AT&T cellular connectivity issues (voice and data) ever since the 1308 update.

afgzee says:

Got the update for my lumia 820 (im in UK) today!

troylytle says:

Done in Middle Tennessee.

Mad MilkMan says:

Whoever was saying that going outside their screen washes out, I have that exact same issue, and I know this is a feature but it still does this with sunlight readabillity turned off, did this since the 1308 update.

theefman says:

Been happening before the 1308 update for me.

Corvodin says:

I'd sure be happy with the 1308 here in Europe :(
 

supsandroid says:

What about att lumias on straight talk?

Updating, Philadelphia PA

pjeung says:

I think its fixed the connectivity issues ladies and gentlemen, good riddance to repeat texts lol!

acrodex says:

Got it updated to 1314. However, I usually have LTE in my office, now it is only 4G.
UPDATE: Never mind, after 10min, it finally switched to LTE.

jmikla says:

AFTER THE UPDATE, MY PHONE DOESN'T RING OR VIBRATE!!! WTF!!!

jmikla says:

False Alarm?!? Weird shit going on with my phone now....

fwaits says:

I would restart it an extra time just to be sure.

JG333 says:

Update installed, hope this resolves the issues I've been having!

Wonder if this will allow me to play MP3 files over bluetooth without any cracking and popping sounds. I keep hoping an update will fix it and am disappointed each time I update and I still have the issue.
How can there be an issue playing a particular file type over bluetooth, but not through the headphone jack!?!?

Jarocookies says:

Does that Bluetooth mp3 file gets a toast message? (there s a problem with this file.......etcetera?) or do you use a a2dr Bluetooth headset I mean

No toast message. It happens with ALL my bluetooth devices. Both of my cars, both of my Nokia 360 NFC/Bluetooth speakers and my BlueAnt bluetooth headset. Hard to get anyone to change it out when it just doesn't make sense.

Jarocookies says:

That's another problem for Nokia ....... good luck anyway!

mrdeezus says:

Had the same issue. its hardware. I still have some akipping though and Nokia says that is aoftware.

Did you get your phone changed out by Nokia or by your carrier?

Yea, definitely hardware. My old 920 had that problem, and I just recently came back to Windows Phone (after switching to a 4s for 2 months), and I haven't had the problem since coming back. I have a red, refurb 920 (bought off Craigslist), and this also has a better screen, doesn't have light leakage, the hardware doesn't creak, no dust in the ffc, and people don't complain that they can't hear me.

blackhawk556 says:

How many times have you informed Nokia about the issue?? Let them know @nokiacareus often that way they can inform the right team.

jayrod213 says:

I just downloaded it in the Chicagoland area.

Miistercoool says:

How come the 920 gets all the updates? How about the 820? No love?

Jarocookies says:

AT&T Lumia 920, Miistercool

Miistercoool says:

-_- I know...just saying the AT&T Lumia 820 should get some updates too :(

mas_bule says:

Installing the update 1314 right now (T-Mobile, The Netherlands)...hopefully everything will go smoothly...

rmichael75 says:

I thought this was for ATT????

pazces84 says:

I think he just wanted to be part of something :)

edsal says:

No update for Lumia 810 ?

xrs22 says:

Just finished.

mrdeezus says:

Downloading now on Sacramento,Ca.

TMavC5 says:

Good to see someone from Sac ;)

cddigi says:

Just got done updating.

Roquenmunoz says:

Anybody else get the spinning gears after trying to install the update?

ChrisLynch says:

That is normal, and takes about 5-10 minutes.  It should then reboot, boot into WP8 and then begin "migrating your data."  The time it takes to migrate greatly depends on how much data you have on your device.

Roquenmunoz says:

Wow fail on my part thanks for the tip!

fpostrow says:

ROTFLMFAO...

cdb033 says:

my gears have been spinning for two hours and still spinning. this is rediculous!!

I didn't get the new storage tools? 

ChrisLynch says:

If you have a L920, scroll all the way to the bottom of Settings, and you will see it.

What do you wanna bet I won't ;) I had to take my last Lumia into AT&T to get it replaced after it bricked during a restore. That Lumia had the latest update on it which had the extra storage settings. While getting it replaced, Nokia stopped rolling out that update because of the connectivity issues. So this new Lumia they gave me wasn't on that update. This is the first update I've gotten for this phone and I don't have that same setting at the bottom. If all of that makes sense. 
EDIT: It showed up. Accessories was the last thing in my list the last time I checked. After letting it sit for a bit and checking it again, it now shows up at the bottom of the list.

Just downloaded in Washington state.

benners76 says:

Doing it now... Passed the spinning gears stage and onto 'Migrating Data'... Fingers crossed. =P

aitt says:

Salute to Nokia.

mas_bule says:

The new storage tool is available and now I'm able to clean temporary files... strangely my firmnr still 1308...everything is working fine...

jayruguitar says:

LTE data connectivity issues seem to have been resolved.  Philly, PA.

xrs22 says:

Mine was in San Antonio, TX.

Engineers says:

Phone still gets hot on top. You would of thought they would of fixed that by now.
 
I hope the battery draining issue got fixed. Very erratic. Some days its fine. Some days its dead by noon with minimal use.
 
Question: what LTE speeds should I get with 2 bars?

Same problem here. Very annoying!

Using the Speedtest app, my LTE speeds are still very, very low even with 4 bars...
2.93 Mbps Down
0.85 Mbps Upload

Seems like I used to get much better results...

Engineers says:

Same here. I used to get over 20Mbps, now I;m getting 5Mbps down and upload speed is terrible

I know it's early, but I don't think this update completly fixed my ATT connectivity issue.
Rebooted, and also did a soft reset. Data speeds are very slow still...

jayruguitar says:

That def doesn't sound right.  I was getting speeds parallel to wohat you're reporting w/ the 1308 update.  After installing the 1314 update my LTE data speeds are hovering around 11Mbps down in Philly, PA.

bpmurr says:

Installed fine on my 920 on the AT&T network.  Only time will tell how well it works.

Rising Mos says:

Installed and working in Colorado ;)

chad08er says:

Update complete,Bakersfield CA.

xrs22 says:

Get the Hardware Test app and it'll tell you what was installed under phone updates

xrs22 says:

After
11.49 mbps download
1.19 mbps upload
84 ms ping
Before
11.57 mbps download
1.47 mbps upload
67 ms ping

blackhawk556 says:

My download seem to have slowed. 6Mbps down from 12Mbps. My upload is crazy though 10mbps

Spicymikey says:

Can't compare like that. Network speed and conditions fluctuate constantly throughout the day for various reasons. My speed can be 30mb at certain times and then drop to 10 on LTE

blackhawk556 says:

Update complete in Fresno.

itsarchie says:

I never had the dreaded connectivity issues on my AT&T 920 after the 1308 update until yesterday.  It drove me nuts and i couldn't make/receive a call or send/receive a text!!!  Hopefully this update fixes it and make everyone happy!

manofice1 says:

downloading and installing now, on ATT on the east coast

ScubaDog says:

Got the update here in sunny Del Rio, Texas.  I wasn't having screen or connectivity problems before, but I love that Nokia is the most up-to-date, responsive OEM on ANY platform.  I've never doubted my choice.

All updated in Big D!

TMavC5 says:

Is it bad i'm getting the gear symbol after installing?

No. This will happen everytime. Only get concerned if it lasts longer than 30 minutes or so...

ncxcstud says:

I was getting worried about it at first... but just as I was about to come here to ask how long it should take it booted right back up :).  Probably about 10 minutes or so (if that long, wasn't paying too much attention to it here at work.  Talking to the cable guy to upgrade us from DSL to cable internet...
Migrating my data now...

TMavC5 says:

How long does it take before this go away?

ncxcstud says:

downloading, updating, 'cogging,' and migrating took around 25 minutes I think...

sqlchicken says:

Updated in Tampa, FL. No issues so far.

paulxxwall says:

What up Tampa ft Myers here read my last post isn't that crazy

paulxxwall says:

Um downloaded update now I'm gettin 20 mbs down 12 mbs up that's awesome!!!! Something's up that's better than my home internet

jmarnell says:

Just showed up on my 920 here in Pittsburgh, PA. Installed and should be good to go.

chuco187 says:

Update loaded successfully! I love this phone and Nokia! Nokia has been one of the best vendors of mobile phone support! Pflugerville, TX

aitt says:

+1 also in Austin.
 

Stewie 1289 says:

Well I still can't clear out temp files, it just continues to spin and spin. ☹

xtrip says:

Im wondering how long will take for Rogers to get it..OTA. Im on Rogers with 1308. I got it on 1308 using the Nokia Software Updater for Retail. However, 1314 is not there...and even if it was, i dont think i want to re-flash it again.
 
 

borasar says:

Rogers didn't even release 1308 OTA yet, so I'm guessing 1314 will be quiet a while!

fpostrow says:

That's odd. Rogers was always first out the door for Gen 1 devices....?

lottidah says:

Update went fine and my surfing is once again speedy!

oldpueblo says:

Any word on internet sharing coming back after the access point firmware?

m0unds says:

really nice of them to send notifications to everyone who contacted them about connectivity issues via twitter too (i was on one of them, got an @mention a bit ago)

pressstart says:

So far so good. Thanks for the update! ;)

SDKevin says:

I love updates!

jehugo says:

What app is that wave in a cube icon?

irvin792 says:

Surf cube 3d browser

ill wait for the gears to stop spinning before ill know if its fixed....

No major problems updating here, except that after the final reboot it got stuck on the blue WP loading screen. Had to do a soft reset, but everything seems to be fine. Just tested my speed, and connecting to a server about 600 miles away gave me speeds of 19 Mpbs down and almost 13 up. No idea why the SpeedTest.net app thinks New York is my closest server, but it worked.

aitt says:

Alot of my tiles are now working again after the update.

i got the 1314 update and don't have the storage tool....odd (on att)

Iain_S says:

the storage tool will be installed sometime after the update as it is done thru the store not the ota update.

surfaced says:

I don't have it too after this AT&T update

Garrett S says:

Updated fine here. It definitely seems to have fixed my issues w/ losing connectivity completely; the phone now switches between HSPA+ and LTE without issue like it used to. Too soon to tell any effects on connection speed or battery life.

smartfonefan says:

Just got 1308 on UK SIM free 920. All went well but on restart it got stuck in flight mode. Reset caused it to tell me it was going to reset...again. All fine now no difference do far. Before update though live tiles weren't updating and screen turned off when I was on a call while trying to access calendar. Also had random reboots especially on wireless charging pad.
I would like a percentage left in the battery on the top of the screen for ...... Sake. Imagine not knowing how long your battery has left and a tile that updated every half hour and appears to be inaccurate, come on Microsoft its fundamental and very necessary and basic......

4Tiles says:

But could also be patented and may be impossible for MS to implement in the OS. That's always been my theory on why no MS products will ever have battery percentage displayed. I could be wrong though. They should do like Xbox does for the controller and have battery bars (5 of them).

mkbruin says:

My ATT 920 wad perfect until the update, but I have had severe battery drain issues since then. Was that one of the 1308 issues? Hope this update fixes that.

chgoflip10 says:

Just finished updating mine now :)  I'm on AT&T.

Just finished updating my AT&T Lumia 920. No problems. I never had LTE/Data problems with the last update, so maybe I'm lucky.
East Bay, California

fbendotti says:

Please post if this fixes issues

austinsmokes says:

In Austin, Tx on AT&T, got the 1314 update installed...  I still cannot text.... OMG!!!   This is horrible.  I rebooted, powered off after that.  I am at a loss for words, which is a first for me.  Connection bouncing around: LTE, 4g, low signal.   Ugh..............
.

Onerunjunior says:

I wish they'd fix a GPS bug in seeing. My phone always thinks I'm in Steinway Station, New York and that's almost a thousand miles away. All my apps that use GPS are useless.

jarala60 says:

MIne was doing the same thing.  After this update, I'm not having that problem..so far.

NYC Just finish updating

Visual360 says:

Just fnished updating, and seems like my touchscreen is phucked up.
 
When I click the power button, and swipe up to unlock the phone, the first swipe doesn't go all the way up (about 1/4-inch off the screen), and will only go the second swipe.
 
Anyone else having this problem??
I have rebooted and change the settings on display+touch.
Quite annoying. :(

S Rodrigo says:

I had that issue in the beginning after the 1308 update. I reset the phone, changed the touch sensitivity to high, turned off the phone, turned it back on, then changed it back to normal and it was working again.

austinlewis says:

Just completed the update in San Francisco. Here are my speedtest results:
BEFORE:
Test Date: 4/11/2013 1:07:28 PM
Connection Type: Cellular
Server: San Francisco, CA
Download: 4.80 Mbps
Upload: 5.79 Mbps
Ping: 66 ms
AFTER:
Test Date: 4/11/2013 1:41:56 PM
Connection Type: Cellular
Server: San Francisco, CA
Download: 7.69 Mbps
Upload: 7.86 Mbps
Ping: 67 ms
 
A SLIGHT improvement. Do those "after" speeds still seem a little slow to everyone else?

m0unds says:

for a congested market? no.

paulxxwall says:

I'm at 20 down 11up after update SW florida

Vectivus says:

Unbelievable, read the article, went to settings, checked for update and it started downloading it!
First time ever for me. Unbranded Lumia 920 in Greece.
It just booted up and is migrating my data, cool :)

mmohn01 says:

Got the update, and on reboot I got the "gears of doom." Gears have been rolling for about 2 hours now.

billziem says:

yep - gears of doom here too. 3+ hours in.

S Rodrigo says:

Its not coming back..see my previous posts on how to reset your phone from being bricked (simple and doesn't involve trying to figure out which firmware you have/need from navifirm).

ATT just told me that after an update or after a new SIM card is installed, LTE can sometimes take a little while to fully kick in....

Pages